ruby setup.rb CentOS 5 syntax error after running

ruby setup.rb CentOS 5 syntax error after running

ruby setup.rb CentOS 5 syntax error after running

[ad#Google Adsense 336 x 280]

# ruby setup.rb
./lib/rubygems.rb:332: warning: parenthesize argument(s) for future version
./lib/rubygems.rb:514: warning: parenthesize argument(s) for future version
./lib/rubygems.rb:30:in `require’: ./lib/rubygems/deprecate.rb:53: syntax error (SyntaxError)
define_method name do |*args, &block| # TODO: really works on 1.8.7?
^
./lib/rubygems/deprecate.rb:54: syntax error
./lib/rubygems/deprecate.rb:63: syntax error
./lib/rubygems/deprecate.rb:68: syntax error from ./lib/rubygems.rb:30
from setup.rb:27:in `require’
from setup.rb:27
#

The solution to do, you must install the ruby version 1.8.7 or above.
To install ruby version 1.8.7

You can use here.
or you can install 1.9 version from here.

Justin Soo is a self-employed Web Development Consultant Specializing, Social Media Content Strategist, Professional Blogger and Computer Engineer. He previous experience in Web Development, Programming, Linux System, MySQL Database. G+ F T In

Tagged with: , , , , ,